Book description
Mac OS X is a stunning technical achievement--a virtually crash-proof Unix core paired with the sleek Aqua interface, bringing style, usability, and stability to a new level. It has almost everything that Macintosh fans have been waiting for: protected memory, crash resistance, and the ability to run the 18,000 existing Mac programs and an unlimited supply of Unix and Open Source software. An instant success among longtime Apple users and developers, the new Mac operating system is becoming the system of choice among serious Unix users as well. There is plenty of territory to explore in Mac OS X, and O'Reilly's latest Nutshell book, Mac OS X in a Nutshell, offers all audiences--both longtime Mac users and converts--the most complete guide to this remarkable operating system. In the tradition of O'Reilly's Nutshell series, this new title offers a thorough treatment of Mac OS X version 10.2, from its BSD Unix foundation to Aqua, the new user interface. The book's "Unix Command Reference" is the most complete and thorough coverage of Mac OS X Unix commands you can find anywhere. Each command and option in this section has been painstakingly tested and checked against Jaguar--even the manpages that ship with the system can't compete in accuracy. The reference incorporates the new command-line tools that come with Apple's Developer tools. It familiarizes readers with the Finder and the Dock, file management, system configuration, network administration issues, and more. Later chapters include bonus material for the Unix user, including advanced use of the Terminal and how to configure a DAMP (Darwin, Apache, MySQL, Perl/PHP) web publishing system. Other topics covered in the book include:
Filesystem overview
Running Java applications
System and Network Administration
Directory Services and NetInfo
Scripting on Mac OS X
Using CVS
Unix Command Reference
Installing and Running X Windows and BSD Unix applications
Mac OS X in a Nutshell follows the common-sense O'Reilly approach, cutting through the hype and giving readers practical details they can use every day. Serious users who want more from their system will find everything they need to know systematically documented in this book. It provides a wealth of knowledge for anyone who wants to make the most of Mac OS X.
Table of contents
-
Mac OS X in a Nutshell
- Preface
-
I. Lay of the Land
- 1. Using Mac OS X
- 2. Using the Finder
- 3. Mac OS 9, Mac OS X,and Classic
-
4. Task and Setting Index
- Accessibility
- Accounts and User Management
- AirPort
- AppleScript
- Background Images
- Classic
- Colors
- Date and Time
- Disks
- Display
- The Dock
- Files and Folders
- Finder
- Fonts and Font Management
- Groups
- Internet, Web, and Email
- .Mac Accounts
- Menu Extras
- Mice, Trackpads, and Scrollwheel Mice
- Modems and Dial-Up Networking
- Networking
- Printer Configuration and Printing
- Screensavers
- Screenshots
- Searching for and Locating Files
- Security
- System Information
- System Status
- Terminal Settings
- Troubleshooting and Maintenance
- Windows
-
II. System Configuration
- 5. System Preferences
- 6. Applications and Utilities
- 7. Networking
- 8. Printer Configurationand Printing
- 9. Filesystem Overview
- 10. Running Java Applications
-
III. System and Network Administration
- 11. System Administration Overview
- 12. Directory Services and NetInfo
- 13. Running Network Services
- 14. Web Publishing with a DAMP System
-
IV. Scripting and Development
- 15. Development Tools
- 16. AppleScript
-
17. Text Editing on Mac OS X
- Types of Text Files
- Property Lists
- Graphical Text Editors
-
Unix Text Editors
- vi
- Movement Commands
- Edit Commands
- Saving and Exiting
- Accessing Multiple Files
- Interacting with Unix
- Macros
- Miscellaneous Commands
- Alphabetical List of Keys
- Setting Up vi
- Emacs
-
Summary of Commands by Group
- File-handling commands
- Cursor-movement commands
- Deletion commands
- Paragraphs and regions
- Stopping and undoing commands
- Transposition commands
- Capitalization commands
- Word-abbreviation commands
- Buffer-manipulation commands
- Window commands
- Special shell characters
- Indentation commands
- Centering commands
- Macro commands
- Basic indentation commands
- Detail information help commands
- Help commands
- Summary of Commands by Key
- Summary of Commands by Name
- Choosing a Default Editor
- Text Encodings
-
18. Using CVS
- Basic Concepts
-
CVS Administrator Reference
- Creating a Repository
- Security Issues
-
Repository Structure
- The CVSROOT directory
- The checkoutlist file
- The commitinfo file
- The config file
- The cvsignore file
- The cvswrappers file
- The history file
- The loginfo file
- The modules file
- The notify file
- The passwd file
- The rcsinfo file
- The readers file
- The taginfo file
- The users file
- The verifymsg file
- The writers file
- Hacking the Repository
- Importing
- Using an Interim Shared Sandbox
- Global Server Option
- Administrator Commands
- CVS User Reference
- CVS in Project Builder
-
V. Under Mac OS X’s Hood
- 19. Using the Terminal
- 20. Pattern Matching
-
21. Shells and Shell Programming
- Introduction to the Shell
- Mac OS X Shells
- tcsh in Detail
- Variables
- Expressions
- Command History
- Command-Line Manipulation
- Job Control
-
Built-in tcsh Commands
- @
- #
- #!
- :
- alias
- alloc
- bg
- bindkey
- break
- breaksw
- built-ins
- bye
- case
- cd
- chdir
- complete
- continue
- default
- dirs
- echo
- echotc
- else
- end
- endif
- endsw
- eval
- exec
- exit
- fg
- filetest
- foreach
- glob
- goto
- hashstat
- history
- hup
- if
- jobs
- kill
- limit
- log
- login
- logout
- ls-F
- newgrp
- nice
- nohup
- notify
- onintr
- popd
- printenv
- pushd
- rehash
- repeat
- sched
- set
- setenv
- settc
- setty
- shift
- source
- stop
- suspend
- switch
- telltc
- time
- umask
- unalias
- uncomplete
- unhash
- unlimit
- unset
- unsetenv
- wait
- watchlog
- where
- which
- while
- 22. The Defaults System
- 23. Running the X Windows System
- 24. Installing Unix Software
-
25. Unix Command Reference
-
Alphabetical Summary of Commands
- ac
- addr
- appleping
- appletalk
- aexml
- appletviewer
- apply
- apropos
- asr
- at
- at_cho_prn
- atlookup
- atprint
- atq
- atrm
- atstatus
- autodiskmount
- automount
- awk
- banner
- basename
- batch
- bc
- biff
- bless
- cal
- calendar
- cancel
- cat
- cd9660.util
- certtool
- checkgid
- chflags
- chgrp
- chkpasswd
- chmod
- chown
- cksum
- clear
- cmp
- colcrt
- colrm
- column
- comm
- compress
- configd
- cp
- cpio
- CpMac
- create_nidb
- crontab
- csmount
- curl
- cut
- date
- dc
- dd
- defaults
- df
- diff
- diff3
- dig
- DirectoryService
- dirname
- disktool
- diskutil
- ditto
- dmesg
- dnsquery
- du
- dynamic_pager
- echo
- egrep
- enscript
- env
- expand
- expr
- false
- fdisk
- fetchmail
- fgrep
- file
- find
- fixmount
- fixPrecomps
- FixupResource-Forks
- fmt
- fold
- fsck
- fsck_msdos
- fs_usage
- fsck_hfs
- fstat
- ftp
- gcc_select
- GetFileInfo
- gnutar
- grep
- gunzip
- gzcat
- gzip
- halt
- hdid
- hdiutil
- head
- hfs.util
- host
- hostinfo
- hostname
- id
- ifconfig
- info
- install
- installer
- ipconfig
- join
- jot
- kdump
- kill
- killall
- ktrace
- last
- leave
- less
- ln
- lnresolve
- locate
- lock
- lockfile
- logger
- look
- lp
- lpc
- lpq
- lpr
- lprm
- lpstat
- ls
- lsbom
- lsof
- machine
- mailq
- mailstat
- makekey
- man
- md5
- merge
- mkbom
- mkdir
- more
- mount
- mount_afp
- mount_cd9660
- mount_cddafs
- mount_devfs
- mount_fdesc
- mount_ftp
- mount_hfs
- mount_msdos
- mount_nfs
- mount_smbfs
- mount_synthfs
- mount_udf
- mount_volfs
- mount_udf
- mv
- MvMac
- nice
- nicl
- netstat
- nidomain
- nidump
- nifind
- nigrep
- niload
- nireport
- niutil
- nslookup
- nvram
- open
- opendiff
- osacompile
- osalang
- osascript
- passwd
- paste
- pax
- pbcopy
- pbpaste
- pdisk
- periodic
- ping
- pl
- pmset
- pr
- printenv
- ps
- pwd
- rcp
- reboot
- renice
- rev
- rlogin
- rm
- rmdir
- rsync
- scp
- screencapture
- script
- scselect
- scutil
- sdiff
- sed
- SetFile
- sftp
- showmount
- shutdown
- slogin
- sort
- slp_reg
- softwareupdate
- split
- SplitForks
- spray
- ssh
- strings
- stty
- su
- sudo
- sw_vers
- SystemStarter
- tail
- talk
- tar
- tee
- telnet
- test
- tftp
- tiff2icns
- tiffutil
- time
- top
- touch
- tr
- traceroute
- true
- tset
- tty
- udf.util
- umount
- uname
- uncompress
- unexpand
- uniq
- units
- unzip
- uptime
- users
- uudecode
- uuencode
- uuidgen
- vi
- view
- vm_stat
- vmmap
- vndevice
- vsdbutil
- w
- wall
- wc
- whatis
- whereis
- which
- who
- whoami
- whois
- window
- write
- xargs
- yes
- zcat
- zcmp
- zdiff
- zgrep
- zip
- zprint
- zmore
- znew
-
Alphabetical Summary of Commands
- A. Resources
- Index
- Colophon
Product information
- Title: Mac OS X in a Nutshell
- Author(s):
- Release date: January 2003
- Publisher(s): O'Reilly Media, Inc.
- ISBN: 9780596003708
You might also like
book
Mac OS X Internals: A Systems Approach
Mac OS X was released in March 2001, but many components, such as Mach and BSD, …
book
macOS Daemonology: Communicate with Daemons, Agents, and Helpers Through XPC
Take advantage of the full power of Swift through XPC. Development for macOS differs from iOS …
book
Troubleshooting CentOS
A practical guide to troubleshooting the CentOS 7 community-based enterprise server In Detail CentOS is the …
book
Linux Shell Scripting Cookbook - Third Edition
Do amazing things with the shell About This Book Become an expert in creating powerful shell …