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At first, gift-giving is fun. During those first 20, 30, or 40 birthday, anniver-
sary, Christmas, thank-you, welcome-to-the-neighborhood, good-luck-in-
your-new-location, sorry-about-the-car, or I-think-you’re-the-cutest-one-

in-the-whole-tenth-grade-class events, you might actually enjoy picking out a present,
buying it, wrapping it, and delivering it.

After a certain point, however, gift-giving becomes exhausting. What the heck do
you get your dad after you’ve already given him birthday and holiday presents for 15
or 35 years?

If you have iPhoto, you’ve got an ironclad, perennial answer. The program’s Book
feature lets you design and order (via the Internet) a gorgeous, linen-covered, 9-by-
11-inch hardbound book, printed at a real bindery and shipped back to you in a
slipcover. Your photos are printed on the glossy, acid-free, single-sided pages, com-
plete with captions, if you like.

A ten-page book costs $30 (extra pages are $3 each). That’s about the least you could
hope to pay for a handsome, emotionally powerful gift guaranteed never to wind up
in an attic, garage sale, or Goodwill shop. In short, it’s a home-run gift every time.

But the iPhoto book is not only a gift. You should also consider ordering them for
yourself—one each for your vacation, wedding, child, or whatever. These books are
amazing keepsakes to leave out on your coffee table—the same idea as most fami-
lies’ photo albums, but infinitely classier and longer lasting (and not much more
expensive).

Publishing a
Photo Book
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Phase 1: Pick the Pix
The hardest part of the whole book-creation process is winnowing down your pho-
tos to the ones you want to include. Many a shutterbug eagerly sits down to create
his very first photo book—and winds up with one that’s 49 pages long (that is, $147).

As a general rule, each page of your photo book can hold a maximum of four pic-
tures. (iPhoto also offers canned book designs called Catalog and Yearbook, which
hold up to 32 tiny pictures per page in a grid. At that size, however, your pictures
don’t exactly sing. Instead, the whole thing more closely resembles, well, a catalog or
yearbook.)

Even the four-per-page limit doesn’t necessarily mean you’ll get 40 photos into a
ten-page book, however. The more pictures you add to a page, the smaller they have
to be, and therefore the less impact they have. The best-looking books generally
have varying numbers of pictures per page—one, four, three, two, whatever. In short,
the number of pictures you’ll fit in a ten-page book may be far lower than 40—25,
for example.

The first step is to create an album (page 114). In Organize mode, fill it with the
pictures you really want in the book.

This can be an excruciating experience, especially if you and a collaborator are try-
ing to work together. (“You can’t get rid of that one! It’s adorable!” “But honey,
we’ve already got 139 pictures in here!” “I don’t care. I love that one.”)

As you work, constantly keep in mind the photo sequence. Drag them around in the
album to determine a preliminary order. You’ll have plenty of opportunity to fine-
tune each page of the book (and rearrange the pictures on it) later in the process.
When you’re still in Organize mode, the only critical task is to place the two most
sensational or important photos first and last (for the cover and the last page of the
book).

Phase 2: Choose a Theme
Once you’ve corralled the book’s pictures into an album of their own, click the al-
bum, and then click the Book button below the main picture area (Figure 10-1). (If
you forget to click the album before clicking Book, iPhoto will scold you.)

Tip: If you’ve been working in some other album, you can save a click by Option-clicking the album that
you want to become a book. Option-clicking a different album in the list always switches into the mode
you’re not currently in: Organize or Book.

Now you see something like Figure 10-1: a large preview page above, and a scrolling
bank of thumbnails below, representing the book’s pages. iPhoto has just turned
into a page-layout program.

Phase 1:
Pick the Pix
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Tip: Light blue lines surround each photo and text box. These guides, as they’re called, won’t appear in
the printed book. They’re there just for your convenience, to help you visualize how the finished layout will
look. Still, if they bother you, turn off the Show Guides checkbox in the lower-left corner of the window.

Before you dive in, take a moment to get your bearings. Note that the thumbnails
are numbered—an early-warning system that shows you how many pages long your
book will be (read: how expensive).

If you’re like most people, your initial layout will be much too long. Not to worry;
you’ll fix that in a moment.

In book-design mode, you can’t add photos to your album, take any photos out, or
even rearrange them. You can perform tasks like these as you work on your book—
but you must click the Organize button to do so.

What you can do, however, is design your book pages, and that process begins when
you choose a theme for the book—a canned design, in other words. Use the Theme
pop-up menu at the lower-left corner of the iPhoto screen for this purpose (shown
in Figure 10-1). Before you begin fiddling with individual pages, try each of the
themes in turn, studying the thumbnails and page previews to get a feeling for the
effect.

Phase 2:
Choose a Theme

Figure 10-1:
In Book mode, there’s a
miniature page-layout
program right in iPhoto. Note
that the picture-size slider is
still present. You can use it to
zoom in or out from the page
you’re working on, which can
be handy when you’re editing
text or captions at small type
sizes.

Page display

Page thumbnailsChoose a theme How many
photos on
this page?

Zoom in/
Zoom out

“Locked”
icon

Page number
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Caution: Choose carefully. You can switch to a different theme for this album later, but you’ll lose all the
custom text and photo groupings you’ve performed so far.

You won’t lose your captions, because those are the Comments stored with every photo in your collection.
“Custom text” refers to the text you type into Introduction pages (page 221) and onto every page of the
Story Book design (page 214). (If you have, in fact, typed any custom text, iPhoto warns you about this loss
when you try to switch layout themes.)

If you want to experiment with a different theme once you’ve spent some time with one, duplicate the
album first. (With the album highlighted in the list, choose File→Duplicate.) Now you can change the
theme on the duplicate without destroying the work you’ve done on the original.

Your choices are:

• Catalog. This design looks
exactly like a mail order
catalog: a picture on the left,
and a name and description
on the right—all eight times
per page (or one, or four).
It’s neatly aligned and some-
what conservative. For ex-
ample, there’s a page design
called Introduction, where
you can pour a lot of text,
such as your shipping poli-
cies, a letter from the
founder, what this season’s catalog offers, and so on.

It’s also good for more than just designing catalogs, however. It would be an ideal
“face book” (with mini biographies) for, say, a dating agency or personnel direc-
tor. It’s also a candidate for a regular photo album, in the event you’re the kind of
person who wants it to look square and gridlike, like a real photo album book
from Office Max.

• Classic. It’s easy to deduce
the philosophy behind this
conservative, clean design:
maximum photos, mini-
mum text. Photos are as
large as possible on the page
(up to four per page), and
each offers only enough
room for a title and a very
short caption.

Phase 2:
Choose a Theme
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• Picture Book. This design’s
philosophy is even starker:
maximum photos, period.
There’s no text, and only
minimum margins. Thus,
on one-photo-per-page
pages, the photo stretches
gloriously from one edge of
the page to the other—a full
bleed, as publishers say.

This dramatic design can be
emotionally compelling in
the extreme. The absence of
text and minimization of
white space seems to make the photos speak—if not shout—for themselves.

As you build your first book, you may be compelled to choose a theme that offers
space for captions. But if your text is no more illuminating than, “Timmy doing a
belly-flop” or “Dad falls asleep at the bar,” consider the Picture Book theme instead.
This is, after all, a photo album, and so it may be worth giving the photos all the
space they deserve. You don’t need to eat into their space by restating the obvious.

Tip: Keeping in mind that the book is published horizontally, in landscape mode, will help you maximize
page coverage. For example, on pages with only one photo, a horizontal shot looks best. It will fill the
page, edge to edge. On pages with two photos, two side-by-side vertical (portrait-mode) shots look best.
They’ll appear side by side, filling the page top to bottom.

• Portfolio. Modeled after a
photographer’s portfolio,
this design has elements of
both Catalog and Picture
Book. Like Catalog, it pro-
vides text boxes that accom-
modate a title and descrip-
tion for each photo. But as
with Picture Book, the pho-
tos are otherwise displayed
at maximum size, with very
little white space between
them.

The whole effect is a tad in-
dustrial-looking, so you probably wouldn’t want to use it as a “memory book”
for some trip or event. It’s useful in situations where Catalog would be right,
except that it’s more interesting to look at, thanks to the varied photo sizes.

Phase 2:
Choose a Theme
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• Story Book. Here’s a
wackier, more energetic lay-
out in which no photos are
square with the page. Every-
thing falls at a tilt, as though
tossed onto a coffee table
helter-skelter. If  there’s
more than one photo per
page, they may even overlap.

The layout isn’t complete
chaos, however, thanks to
the text boxes for captions,
which are always parallel to
the page edges and therefore
anchor the design. Overall, this theme is livelier than the others; use it when fun,
craziness, or lightheartedness is your desired effect.

• Year Book. This theme lets
you fit up to 32 photos on
each page—just as in a high
school yearbook. Of course,
if you choose greater quan-
tities, the photos themselves
get smaller—but iPhoto al-
ways leaves you enough
room for a title (“Chris
Jones”) and a little descrip-
tion (“Swim team ’02; voted
Most Likely to Enter the
Priesthood”).

Tip: Make an effort to choose a quantity of photos that neatly fills the final page, or at least a row of it.
Otherwise, the final page can look a bit half-finished.

Try choosing each of these themes in turn from the Themes pop-up menu. The
thumbnails of your pages should give you immediate feedback about the suitability
of each design for your book project.

Phase 3: Design the Pages
Once you’ve selected an album and a theme, the most time-consuming phase be-
gins: designing the individual pages.

It’s important to understand that iPhoto thinks of the pictures in your book as a
continuous stream that flows from left to right, in precisely the same order as in the

Phase 2:
Choose a Theme



chapter 10: publishing a photo book 215

album you’ve selected. You can drag your page thumbnails around with the mouse
to rearrange them—but behind the scenes, you’re simultaneously rearranging the
photos in the album. Similarly, if you drag photos around in the Organize window
for your album, you’ll wind up rearranging the pages of your book. Figure 10-2
should drive this point home.

Tip: You’ll soon discover that designing a book is a much happier experience if you work on your pages
strictly from left to right. Doing so reduces the likelihood that your photos will sproing out of order unex-
pectedly, as described on page 219.

To begin work on a page, click its thumbnail. Now you have three decisions to make:
how many photos should appear on this page, what text should appear, and what
the text should look like.

Figure 10-2:
Top: There’s a rigid correspon-
dence between the order of
the photos in your book and
the order they appear in the
album (in Organize mode).

Bottom: If you drag a page
into a new position in Book
mode, you’ll find the photos’
new order reflected in
Organize mode. See how the
two circled photos have
moved in the lower shot of
Organize mode?

Book mode

Organize mode

Book mode

Organize mode

Before:

After:

Phase 3:
Design the Pages
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Tip: Even in Book mode, you can still rotate photos, rename them, change their dates, or delete them, just
as you would thumbnails in Organize mode (see Chapter 5).

The Cover
Start with the Cover page—the first thumbnail in the row. When it’s selected, the
cover photo appears in the main picture area. This is the picture that will be pasted
(and centered) on the linen cover of the actual book. (The cloth cover of your book
will be one of several handsome dark colors, not white as it appears here.)

You can’t do much with the cover except to change the title or subtitle; see “Editing
titles and captions,” below. You’ll choose the cover color in a later step.

Tip: The picture you see here is the first picture in the album. If it’s not the photo you want on the cover,
click the Organize button and drag a different photo to the beginning of your album.

Pictures per Page
Click the thumbnail for page 2. If you did some preliminary arranging work in your
album, your photos should already be in roughly the right order for the book pages—
but not necessarily the right groupings.

You control how many pictures appear on a page—and, to an extent, their layout—
by choosing a number from the Page Design pop-up menu. Your choices are:

• Cover. The first thumbnail in your book must have the Cover design.

On the other hand, subsequent pages can also have the Cover layout. You can use
this quirk to your advantage. For example, in a book that documents your trip to
three countries, you can have a “cover” layout that introduces each country’s batch
of photos.

• Introduction. In most themes, this special page design has no photos at all. It’s
just a big set of text boxes that you can type (or paste) into. Here’s where you can
let the audience know about the trip, the company, or the family; tell the story
behind the book; praise the book’s lucky recipient; scare off intellectual-property
thieves with scary-sounding copyright notices; and so on.

Cover = Page in the Album
I want to use my cover photo as one of the pages in the
book, just like they do in real coffee-table photo books.
How do I do it?

In Organize mode, click the photo and then choose
File→Duplicate (c-D).

Now you have two copies of the photo. Drag one to the
front of the line in the album (to use as the cover). Drag
the other into the mass of other photos, so that you can
now use it in one of the interior page layouts.

FREQUENTLY ASKED QUESTION

Phase 3:
Design the Pages
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Tip: An Introduction page (one of the choices in the Page Design pop-up menu) doesn’t have to be the
first page of the book (after the cover). You can turn any page into an Introduction page. Such pages make
great section dividers.

They’re especially useful in designs that use the Picture Book theme that otherwise have no text at all. An
Introduction page can set the scene and explain the following (uncaptioned) pages of pictures.

• One, Two, Three, Four…. Use these commands to specify how many photos ap-
pear on the selected page. iPhoto automatically arranges them according to its
own internal sense of symmetry.

Case of the Hideous Layout
Oh my gosh, you can’t believe how ragged my book pages
look. They don’t look anything like the tidy illustrations in
this chapter, or the examples on the Apple Web site. What’s
going on?

iPhoto’s design templates
operate on the simple
premise that all of your
photos have a 4:3 aspect
ratio. That is, the long and
short sides of the photo
are in four-to-three pro-
portions (four inches to
three inches, for example).

In most cases, that’s what
you’ve already got, since
those are the standard
proportions of standard
digital photos. If all your
pictures are in 4:3 (or 3:4) proportions, they will fit neatly
and beautifully into the page-layout slots iPhoto provides
for them.

A few cameras produce photos in the more traditional 3:2
film dimensions (1800 x 1200 pixels, for example), and
some cameras let you choose. That feature will make you
very happy when it comes time to order Kodak prints of
your pictures (Chapter 8)—but will cause you nothing but
headaches when you want to lay out a photo book. They
won’t align with the canned iPhoto designs, and full-bleed
(edge-to-edge) pictures won’t go edge to edge. They’ll leave

unsightly strips of white along certain edges.

Another possibility: You may have made the mistake of
mis-cropping your photos in iPhoto. When you arbitrarily
chop out excess portions of your pictures, you lose the

tidy 4:3 aspect ratio they
were born with. You wind
up with one picture that’s
4:2.5, another that’s 5:3,
and so on. These photos
won’t line up when placed
into a book layout, either.

The simple way to avoid
these problems is to crop
your non-4:3 photos using
the Constrain pop-up
menu (page 133). Choose
“4 x 3 (Book, DVD)” from
this menu to crop safely.

Now, even though you’re chopping away edges of your
photo, you’re maintaining the ideal book proportions.

If you’ve already done unconstrained cropping—if you’re
reading this advice too late, and you’ve got uneven lay-
outs in your book—you have only one recourse. Click Or-
ganize, click the pictures you cropped, and choose
File→Revert to Original. Thanks to iPhoto’s secret backup
system (page 146), you now have the photos as they were
when they first arrived from the camera. You can now re-
crop them, this time using the Constrain menu to keep the
proportions pure.

FREQUENTLY ASKED QUESTION

Phase 3:
Design the Pages
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First-time iPhoto book designers frequently complain that they have no control
over the placement of the photos within the page. You can’t drag the bottom
picture up to the top, for example.

It’s true that you can’t rearrange pictures by dragging them—but that doesn’t
mean you can’t rearrange them at all. Remember that the photos’ order on the
book pages is a mirror of their order in the album. Just click Organize, drag the
photos into a new sequence, and then click the Book button again. You’ll see the
change reflected immediately.

Otherwise, you are indeed at the mercy of iPhoto’s design templates. In the Story
Book theme, for example, you can’t dictate which photos overlap their neighbors
or how they overlap. In the Picture Book theme, you can’t control which photos
are half-size and which are quarter-size. And so on.

• End. The Page Design pop-up menu for the Story Book theme offers a bonus
page design called End. Use it for the last page of the book.

The End page is designed to hold three pictures, and you’d be well advised to
fiddle with your album until the last page does, in fact, have three photos on it.
Otherwise, you’ll wind up with a strange, half-filled look on the End page. For
example, if there’s only one photo on it, that picture will sit halfway off the left
margin, as though sailing off to the left (“later dude!”), and the rest of the page
will be blank.

Figure 10-3:
Top: Suppose iPhoto
proposes putting two photos
on page 3. (Note the all-black
photo on page 4.)

Bottom: When you choose
Three from the Page Design
menu, you’re telling iPhoto
that you want three photos
on page 3. The program
responds by sucking in the
next photo (on the next
page) to fill its quota. Yes,
there are now three pictures
on page 3, as you re-
quested—but the all-black
square photo has now left
page 4, causing all photos
after it to slide leftward,
rippling all the way through
your book.

Page 3 starts
with two photos...

Now it has three, having sucked in
a new photo from page 4.

...but you’re asking
for three.

Phase 3:
Design the Pages
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Tip: Normally, your selection from this pop-up menu affects only the page you’re working on. But if you
want all the pages to look the same, hold down Option as you pick a design. iPhoto applies that design to
all pages in the book. (Needless to say, this business involves re-laying out all of your pages, even those
that you’d locked.)

Each time you change the number of photos on a page, something happens that you
may find disconcerting: Pictures on the following pages slide onto earlier or later
pages. Figure 10-3 illustrates this phenomenon.

This syndrome can drive you wiggy if it winds up disrupting a page that you’ve
already tweaked to perfection—a problem you’ll almost certainly encounter if you
don’t work on your pages from left to right.

The solution is simple. Once a page has the right photos on it (and the right number
of photos), lock it by turning on the Lock Page checkbox at the lower edge of the
window. (A tiny padlock icon appears on the page’s thumbnail, as shown in Figure
10-1.)

From now on, even if you change the number of shots on an earlier page, the page
you locked will remain undisturbed.

Even this trick, though, requires some caution. Keep in mind the following gotchas:

• Once you’ve locked a page, the Page Design pop-up menu no longer functions
for that page. You have to unlock a page before you can change the number of
pictures on it.

• If you do unlock a page, watch out…you’re taking the muzzle off of a spring-
loaded design. Because iPhoto is maintaining a picture group that, in its head, is
out of sequence (relative to Organize mode), unlocking a page may cause its
pictures to explode into other locations. As a result, you’ll witness a ripple effect
that’s likely to scramble all unlocked pages in your book.

• If you use the Theme pop-up menu to change themes, all bets are off. Changing
themes blasts all layout work into oblivion, locked or not.

Yo…where’s the Save command?

There isn’t one. iPhoto automatically saves your work as
you go.

If you want to make a safety copy along the way—a fallback
version—highlight the album from which the book is de-

The Save Command

FREQUENTLY ASKED QUESTION

rived and choose File→Duplicate. This process takes vir-
tually no extra memory or disk space, but it’s good insur-
ance. If you change the layout or theme of a book, iPhoto
vaporizes all the text you’ve entered (and, often, a lot of
the layout work). If that happens, you’ll be glad you had a
backup.

Phase 3:
Design the Pages
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Page Sequence
As you work, continue to consider the overall effect of your layout. You already know
that you can rearrange the photos (by clicking the Organize button and then drag-
ging them), but you can also rearrange entire pages. Just drag the thumbnails left or
right in their track. (If you return to Organize mode, you’ll see that the photos have
shifted there, too, to reflect their new order in the book; see Figure 10-2.)

Sometimes chronological order is the natural sequence, especially for books that
will be mementos of special events like trips, parties, and weddings. But there’s noth-
ing to stop you from cheating a bit—rearranging certain scenes—for greater impact
and variety.

As you drag your pictures into order, consider these effects:

• Intersperse group shots with solo portraits, scenery with people shots, vertical
ones with horizontals.

• On multiple-photo pages, exploit the direction your subjects face. On a three-
picture page, for example, you could arrange the people in the photos so that
they’re all looking roughly toward the center of the page, for a feeling of inclu-
sion (Figure 10-4). You might put a father looking upward to a shot of his son
diving on a photo higher on the page, or a brother and sister back-to-back facing
outward, signifying competition.

• Group similar shots together on a page.

Figure 10-4:
Variety is good—but thematic unity
is good, too. Here, two photos
taken at the same event, moments
apart, feel good together. They tell
a little scene and add a little action
to your book.

Phase 3:
Design the Pages
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Page Limits
The book can have anywhere from 10 to 50 pages. If you create fewer pages, you’ll be
warned during the book-ordering process that you’re about to pay for a ten-page
book with blank pages at the end. If you create more than 50 pages, you won’t be
allowed to place the order at all.

There’s nothing to stop you from creating multiple books, however. (“Our Trip to
New Jersey, Vol. XI,” anyone?)

Hiding Page Numbers
Each built-in theme includes page numbers stamped on the lower-right corner of
each page. You never have to worry about a page number winding up superimposed
on one of your pictures, though. A picture always takes priority, covering up the
page number.

Even so, you may feel that page numbers intrude on the mood your book creates. If
so, just eliminate them by turning off the Page Numbers checkbox at the lower-left
corner of the window.

Tip: As you work, you may discover photos here and there that need a little editing—cropping, brighten-
ing, and so on (Chapter 6). No problem: Just double-click a picture right in the book-page display window
to open it into either Edit mode or an external photo-editing program, as described on page 144. Close the
editing window, or click the Book button again, when you’re finished.

Phase 4: Edit the Titles and Captions
In every theme, iPhoto offers you text boxes that you can fill with titles, explana-
tions, and captions. Most layouts have space for this kind of text on every page. Only
the Picture Book design is text-free (except for the cover and introduction page).

In any case, taking the time to perfect this text is extremely important. A misspelling
or typo you make here may haunt you (and amuse the book’s recipient) forever.

In general, iPhoto offers the following four kinds of text boxes:

• The book title. This box appears on the book’s cover and (if you’ve added one)
Introduction page. When you first create a book, iPhoto proposes the album’s
name as the book name, but you’re welcome to change it.

A second text box, all set with slightly smaller-type formatting, appears below
the title. Use it for a subtitle: the date, “A Trip Down Memory Lane,” “Happy
Birthday Aunt Enid,” “A Little Something for the Insurance Company,” or what-
ever.

• The introduction. Applying the Introduction page design to a page gives you a
huge text block that you can fill with any introductory text you think the book
needs.

Phase 3:
Design the Pages
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Tip: An Introduction page doesn’t need to be the first page of the book (after the cover). You can turn any
page into an all-text Introduction page. Such pages make great section dividers.

They’re especially useful in Picture Book designs that otherwise have no text at all. Whatever you type or
paste into the Introduction page can set the scene and explain the following (uncaptioned) pages of
pictures.

• Photo titles. In most layouts, iPhoto displays the name of each photo. If you
haven’t already named each picture, you’ll get only the internal iPhoto name of
each picture—“Roll 132-101,” for example. You can edit this name either in the
text box on your page preview, or in the Title text box at the left side of the iPhoto
window (Figure 10-5).

• Comments. The larger text box that appears for each photo (in some layouts) is
for a caption. It automatically displays any comments you’ve typed into the Com-
ments box for a photo at the left side of the iPhoto screen (see page 109). Or, to
be precise, it displays the first chunk of that text (Figure 10-5).

Note, by the way, that some of the layouts don’t show nearly as much text as the
“real” Title or Comments box does. In these cases, iPhoto has no choice but to

Figure 10-5:
iPhoto offers two different
places for you to enter
text. Using the boxes at the
left side of the screen is
usually faster, since you
don’t have to wait for
iPhoto to zoom in to the
text box. A yellow,
nonprinting warning sign
appears if the text box is
too small to display all of
the comment text (or the
full photo name).

“Real” title and
comment boxes

On-page title and
comment boxes

Text overflow warning

Phase 4: Edit the
Titles and Captions
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chop off the excess, showing only the first sentence or two. A yellow, triangular
exclamation point appears next to any text box that has overflow of this kind—
your cue to edit down the text to fit the text box on the layout (Figure 10-5).

Note: On the other hand, iPhoto may give you “false positives,” showing a yellow triangle (and text
visually wrapping on the screen) when, in fact, the text will look just fine when it’s printed. (This problem
is especially apparent with small text and a reduced-size display of the page.) To find out what you’ll really
get, make a final proofreading pass using one of the techniques described on page 228.

Editing Text
You’re welcome to edit the photo titles or comments in either place: right here in the
layout, or back in the Info box for the individual photos (page 109). In general, the
editing process is straightforward. Just proceed like this:

• Click inside a text box to activate the insertion-point cursor, so you can begin
typing. iPhoto zooms in on the page and scrolls it, if necessary, so that the type is
large enough to see and edit. When you click outside a text box—on another part
of the page, for example—the page shrinks again to fit the window.

• You can select text and then use the Edit menu’s Cut, Copy, and Paste commands
to transfer text from box to box.

• You can also move selected text within a text box by dragging it and dropping it.
The trick is to hold down the mouse button for a moment before dragging. Add
the Option key to make a copy of the selected text instead of moving it.

• Double-click a word, or triple-click a paragraph, to neatly highlight it.

• Press Control-right arrow or Control-left arrow to make the insertion point jump
to the beginning or end of a text box.

• To make typographically proper quotation marks (“curly like this” instead of
"this"), press Option-[ and Shift-Option-[, respectively. And to make a true long
dash—like this, instead of two hyphens—press Shift-Option-hyphen.

But here’s the biggest tip of all: Edit your text in Preview mode. (Click the Preview
button at the lower-right corner of the window; see Figure 10-9.) In Preview mode,
each page appears in its own window, which you can make as large as you like.
iPhoto therefore doesn’t have to zoom and unzoom as you click each text box, which
makes the editing go faster. And because you can see the whole page (instead of only
the portion that fits within the photo viewing area), you have a better sense of your
text block’s look and proportions relative to the picture.

Tip: Click the green Zoom button at the left end of the title bar to make the page fill your screen. The
result: An even more expansive canvas in which to work.

Phase 4: Edit the
Titles and Captions
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Hiding Text
As noted earlier, the Picture Book theme is especially dramatic because it lacks text.
The pictures spill across the pages, strong and big.

Bear in mind, though, that you can turn off the text for any of the layout themes.
Just turn off the corresponding checkbox (Titles or Comments) in the lower-left
corner of the iPhoto window. (You can also leave individual boxes empty, of course.)

Note: You can’t add titles or comment boxes to a theme that doesn’t have them, however. The pages in
the Picture Book theme don’t have any text on them, and no amount of turning the Titles and Comments
checkboxes on or off can change that.

Formatting Text
To a certain extent, you can change the fonts, sizes, and styles of type in your book.
To begin, choose Edit→Font→Show Fonts (or press c-T). As shown in Figure
10-6, Mac OS X’s standard Font panel appears.

Now click inside the kind of text box you want to change, and then click any font,
style, or type size you like. All right, “any” may be stretching it. The truth is:

• You can’t change the size of the type—only the font and style.

Figure 10-6:
This is the Font panel, a standard type-
choosing dialog box in certain Mac OS X
programs. (It generally appears only in so-
called Cocoa programs—those that have
been written from scratch for Mac OS X
rather than adapted from a Mac OS 9
version.) You should ignore the Sizes
column because it doesn’t work in iPhoto.

Phase 4: Edit the
Titles and Captions
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• In general, whatever changes you make apply to every title or comment box in
the entire book. There’s no way to make one caption look different from other
captions, or to format only part of a sentence (so that you can italicize a single
word, for example).

• There are two exceptions to the previous point. If you select some words and
then Control-click them, a contextual menu appears. Choosing Italic or Bold
from its Font submenu affects all text in all boxes—but choosing Underline af-
fects only the selected words. (It looks pretty crude, but that’s a different conver-
sation.)

The Font submenu even offers a Show Colors command. It opens a color palette;
using it, you can apply different colors, too, to individual text selections. Yes, the

Phase 4: Edit the
Titles and Captions

As you work on your book design, you may encounter the
dreaded yellow-triangle-exclamation point like the one
shown here. It appears everywhere you want to be: on the
corresponding page thumbnail, on the page display, on
the page preview (which appears when you click Preview),
and so on.

If you actually try to order the book without eliminating
the yellow triangles, you even
get a warning in the form of a
dialog box. “Low Quality Warn-
ing: One or more photos in
your book may print at too low
a quality based on the design
you have chosen. Do you want
to continue?”

All of this boils down to one
heartbreaking problem: At least one of your photos doesn’t
have enough resolution (enough pixels) to reproduce well
in the finished book. If you ignore the warning and con-
tinue with the ordering process, you’re likely to be disap-
pointed by the blotchy, grainy result in the finished book.

You may remember from Chapter 1 that the resolution of
your digital camera is relatively irrelevant if you’ll only be
showing your pictures onscreen. It’s when you try to print
them that you need all the megapixels you can get—like
now.

The Heartbreak of the Yellow Exclamation Point

UP TO SPEED

The easiest solution is to shrink the photo on its page. And
the easiest way to do that is to increase the number of
pictures on that page. (Some layouts put both large and
small photos on the same page. In that case, you may have
to click Organize and drag photos around so that your low-
res, problem-child picture lands in one of the smaller slots.)

Decreasing a picture’s size also squeezes its pixels closer
together, improving the dots-
per-inch shortage that iPhoto
is warning you about.

If even that dramatic step
doesn’t eliminate the yellow
warning emblems, try to re-
member if you ever cropped
this photo. If so, your last
chance is to click Organize, click

the photo, and then choose File→Revert To Original. Do-
ing so will undo any cropping you did to the photo, which
may have thrown away a lot of pixels that you suddenly
find yourself needing. (If Revert To Original is dimmed,
then you never performed any cropping, and this last re-
sort is worthless.)

Finally, if nothing has worked so far, your only options are
to eliminate the photo from your book or to order the book
anyway.
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bright, multicolored result might look a little bit like it was designed by Barney
the Dinosaur, but the Color option is worth keeping in mind when you’re pre-
paring books about, for example, someone’s fourth birthday party.

Check Your Spelling
Ordinarily, you might scoff at the overkill—what difference does a typo make in a
photo-organizing program, for goodness’ sake? But your tune will change the very
day you get your $30 (or $150) hardbound photo book in the mail, proudly titled,
“Our Trip to the Grand Canyin.”

As in a word processor, you can ask iPhoto to check your spelling several ways:

• Check a single word or selection. Highlight a word, or several, and then choose
Edit→Spelling→Check Spelling (c-semicolon). If the word is misspelled in
iPhoto’s opinion, a red, dashed line appears under the word. Proceed as shown in
Figure 10-7.

• Check a whole text block. Click inside a title or comment box and then choose
Edit→Spelling→Spelling (Shift-c-semicolon). The standard Mac OS X Spell-
ing dialog box appears, also shown and described in Figure 10-7.

Phase 4: Edit the
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Figure 10-7:
Top: Control-click any word that’s underlined with a
dashed, red line. If the resulting contextual menu
contains the correct spelling, choose it. Otherwise,
choose Ignore or Add (to teach Mac OS X that word
for future spell checks).

Bottom: If you prefer a more word-processorish
spelling check, you can summon this box.

The first “misspelled” word already appears. If the
correct version appears in the list, double-click it (or
single-click it and then click Correct). If not, type the
correct word into the box below the list and then
click Correct.

On the other hand, if the word in your caption is
fine as it is, click either Ignore (“Stop underlining
this, iPhoto. It’s a word I want spelled this way; let’s
go on”) or Add (“This is a name or word that not
only is correctly spelled, but I may use again. Add it
to your dictionary so you’ll never flag it again”).
Alas, iPhoto forgets everything you've told it to
Ignore as soon as you click into a different text box.
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• Check as you type. The trouble with the spelling commands described here is
that they operate on only a single, tiny text block at a time. To check your entire
photo book, you must click inside each title or caption and invoke the spelling
command again. There’s no way to have iPhoto sweep through your entire book
at once.

Your eyes might widen in excitement, therefore, when you spot the Edit→
Spelling→Check Spelling As You Type command. You’d expect it to make iPhoto
flag words it doesn’t recognize as you type them.

Sure enough, when this option is turned on, whenever you type a word not in
iPhoto’s dictionary, iPhoto adds a colorful dashed underline. (Technically, it un-
derlines any word not in the Mac OS X dictionary, since you’re actually using the
standard Mac OS X spelling checker—the same one that watches over you in
Mac OS X’s Mail program, for example.)

To correct a misspelling that iPhoto has found in this way, Control-click it. A
contextual menu appears. Proceed as shown in Figure 10-7.

There’s only one problem: This option turns itself off every time you click into a
new text box. Using the mouse (there’s no keyboard shortcut), you have to turn it
on again for every title and caption. The regular Check Spelling command looks
positively effortless by comparison.

Listen to Your Book
Unfortunately, even a spelling checker won’t find missing words, inadvertently re-
peated words, or awkward writing. For those situations, what you really want is for
iPhoto to read your captions aloud to you.

No problem: Just highlight some text by dragging through it, and then Control-
click the highlighted area. As shown in Figure 10-8, a contextual menu appears,
containing the Speech command.

Figure 10-8:
Control-clicking highlighted
text produces this secret
contextual menu, which
includes commands that make
iPhoto start and stop reading
the text aloud. It uses
whatever voice you’ve selected
in Mac OS X’s System
Preferences→Speech control
panel.

Phase 4: Edit the
Titles and Captions
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Phase 5: Preview the Masterpiece
Ordering a professionally bound book is, needless to say, quite a commitment. Be-
fore blowing $30 or more on a one-shot deal, you’d be wise to proofread and inspect
it from every possible angle.

Preview It Onscreen
One easy way to inspect your book is to click the Preview button in the lower-right
corner of the screen. iPhoto fills your screen with an electronic version of the se-
lected page for your inspection, as shown in Figure 10-9.

Print It
As any proofreader can tell you, though, looking over a book on paper is a sure way
to discover errors that somehow elude detection onscreen. That’s why it’s a good
idea to print out your own, low-tech edition of this book at home before beaming it
away to Apple’s bindery.

While you’re in Book mode, choose File→Print. After the standard Mac OS X Print
dialog box appears, fire up your printer and click Print when ready. The result may
not be linen-bound and printed on acid-free paper, but it’s a tantalizing preview of
the real thing—and a great way to give the book one final look.

Turn It into a PDF File
Sooner or later, almost everyone with a personal computer encounters PDF
(Portable Document Format) files. Many a software manual, Read Me file, and

Figure 10-9:
In Preview mode, you can
flip through your book one
page at a time by clicking
the arrows at the top. (You
can also jump to a certain
page by typing a number
into the box and then
pressing the Return key.)
For best results, click the
Zoom button to make
the window as large as
possible on your screen.
You can turn off the light
blue box boundaries, if you
like, by turning off “Show
Guides.”

Zoom button

Previous page

Next page

Phase 5: Preview
the Masterpiece
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downloadable “white paper” comes in this format, for many of the following rea-
sons:

• Other people see your layout. When you distribute PDF files to other people,
they see precisely the same fonts, colors, page design, and other elements that
you did in your original document. They get to see all of this even if they don’t
have the fonts or the software you used to create the document. (Now contrast
this with the alternative: sending somebody, for example, a Microsoft Word docu-
ment. In this scenario, if your correspondents don’t have precisely the same fonts
as you, then they’ll see a screwy layout. And if they don’t have Microsoft Word,
they’ll see nothing at all.)

• It’s universal. PDF files are very common in the Macintosh, Windows, and even
Unix/Linux worlds. When you create a PDF file, you can distribute it (by email,
for example) without ever worrying about what kind of computers your corre-
spondents are using. All the recipient needs is a copy of the free Adobe Acrobat
Reader program, which now comes preinstalled with every computer.

• It has very high resolution. PDF files print at the maximum quality of any printer.
A single PDF file prints great both on cheapo inkjets and on high-quality image-
setting gear at professional print shops. (You’re looking at a PDF file right now,
in fact, which was later printed at a publishing plant.)

• You can search it. Although you may be tempted to think of a PDF file as some-
thing like a captured graphic of the original document, it has several key differ-
ences. Behind the scenes, its text is still text. You can search it using a Find com-
mand.

If you suspect other people might want to have a look at your photo book before it
goes to be printed—or if they’d just like to have a copy of their own—a PDF file
makes a convenient, emailable package.

Here’s how to create a PDF file:

1. With your book design on the screen in front of you, choose File→Print.

The print dialog box appears.

2. Click the Save as PDF button.

The Save sheet appears.

3. Type a name for the file, choose a folder location for it, and click Save.

Your PDF file is ready to distribute. (Fortunately, the recipients will be able to
correct the rotation within Adobe Acrobat, using its View→Rotate Counterclock-
wise command.)

Phase 5: Preview
the Masterpiece
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Phase 6: Send the Book to the Bindery
When you think your book is ready for birth, click the Organize button. In the row
of icons at the bottom of the screen, click Order Book.

After several minutes of converting your screen design into an Internet-transmit-
table file, iPhoto offers you a screen like the one shown in Figure 10-10. (If your
book is shorter than ten pages, iPhoto first warns you that you’re about to pay for a
bunch of blank pages. Ten pages is the minimum for a book.)

Note: If you receive a Low Quality Warning at this stage, see the box on page 225.

At this stage, your tasks are largely administrative.

• Choose a cover color. Use the Cover Color pop-up menu to choose Black, Bur-
gundy (red), Light Gray, or Navy (blue). The books in the illustration, including
the handy magnified swatch, change color to show you what you’re getting. (If
you’re ordering more than one book, they must all have the same color.)

• Inspect the charges. If you’ve gone beyond ten pages, you’ll see that you’re about
to be charged $3 per additional page.

Figure 10-10:
Bottom left: Choose a
color, a quantity, and
a recipient.

Top right: You won’t be
allowed to choose a
quantity or recipient,
though, until you’ve first
signed up for an Apple ID
and turned on 1-Click
Ordering, which you’ll
enjoy using over and over
again to order books and
stuff from the Apple
online store.

Later, if you want to
troubleshoot or change
your Apple ID settings,
visit www.myinfo
.apple.com.

Phase 6: Send the
Book to the Bindery
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• Indicate the quantity. You can order additional copies of the same book. Indeed,
after you’ve spent so much time on a gift book for someone else, you may well be
tempted to order yourself a copy.

Your Apple ID
You can’t change the quantity, however, or indeed make any additional progress
until you’ve signed up for Apple’s 1-Click Ordering system. And to do that you need
an Apple ID (or a .Mac ID). And to do that you must proceed like this:

1. Click “Enable 1-Click Ordering.”

Now you see a dialog box that invites you to type in your Apple ID and password,
if you have them. If so, fill them in by all means. An Apple ID is your email
address. It’s the same ID you use to customize the look of Apple’s help Web site
(if you’ve ever done that) or to buy something from the online Apple store.

2. Click Create Apple ID.

The Create an Apple ID screen appears. (If you have a .Mac email address, that’s
your Apple ID.)

Phase 6: Send the
Book to the Bindery

directly from iPhoto, rather than uploading photo files one
at a time using your Web browser.

Still, you should know that build-
ing your books directly at
MyPublisher.com offers greater
design freedom than iPhoto
does. You have greater choices
of cover colors and materials
(even leather), you can add a
glossy dust jacket, you can add
borders around the pages, you
have your choice of lightly pat-
terned backgrounds, and you
have much more flexibility over
the placement of photos and text.

In fact, it’s easy to get carried away with these options and
produce something absolutely ghastly, which is probably
why Apple chose to limit your options so you simply can’t
go wrong.

It’s no secret that when you order prints of your photos via
the Internet, Kodak makes the prints. But neither tempta-
tion nor torture will persuade
Apple to reveal who makes the
gorgeous iPhoto photo books.

It didn’t take long for Mac fans
on the Internet, however, to dis-
cover some astonishing similari-
ties between the iPhoto books
and the books created by a firm
called MyPublisher.com. The
pricing, timing, and books them-
selves are all identical. (When
asked if it’s Apple’s publishing
partner, MyPublisher.com says,
“We don’t discuss our partner relationships,” which means
“Yes.”)

The truth is, iPhoto-generated books are more elegantly
designed than the ones you build yourself at
MyPublisher.com. And it’s certainly easier to upload books

Secrets of the Apple Book Publishing Empire

WORKAROUND WORKSHOP
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3. Fill in your email address, a password (twice), a question (which you’ll be asked
if you forget your password) and its answer, and your date of birth.

Unless you enjoy receiving junk email, turn off “I would like to receive Apple
news, software updates, special offers, and information…from other compa-
nies.” Note, too, that Apple ships books only to people in the U.S. and Canada.

4. Click Continue; on the Terms of Use screen, click Accept.

Now you’re asked for your billing information (top right in Figure 10-10). This
is how you’ll pay for the book, and all books to come.

5. Fill in your billing information, and then click Continue.

iPhoto lets you set up a number of addresses for people you may want books
shipped to. The next screen proposes that you add yourself to this list.

6. Click Continue.

You wind up right where you started: at the Order Book screen. This time, how-
ever, the controls at the bottom are “live” and operational.

7. From the Ship To pop-up menu, choose the lucky recipient of this book.

If it’s you, choose Myself. If not, choose Add New Address from this pop-up
menu. Fill in your Apple ID and password to prove that you’re you (you cer-
tainly wouldn’t want some hacker adding addresses to your list!). Click Sign In,
and then, on the next screen, fill in the new address. When that’s done, click
Apply (if you intend to add yet another address) or Save (if that’s it for now).

If you wind up at the 1-Click Account Summary screen, click Done.

8. From the Ship Via pop-up menu, indicate how you want the finished book
shipped.

“Standard” shipping takes about four days and costs $8. “Express” means over-
night or second-day shipping (depending on when you place the order) and
costs $13. An additional book sent to the same address costs another $1 for Stan-
dard shipping, or $2 for Express.

9. Indicate how many copies of this book you want, using the Quantity control.

You’ll see the Order Total updated.

10. Click “Buy Now With 1-Click.”

You’ve already stored your credit card information, so there’s nothing to do now
but wait for your Mac to upload the book itself. After a few minutes, you’ll see a
confirmation message.

Phase 6: Send the
Book to the Bindery
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11. Go about your life for about four days, holding your breath until the book
arrives.

You’ll certainly be impressed by the linen-covered cover and the heavy, glossy
pages. The photos themselves are printed on Indigo digital presses (fancy digital
four-color offset machines), but aren’t what you’d call Kodak quality—or even
photo-inkjet-on-glossy-paper quality.

But the book itself is classy, it’s handsome…and it smells good!

Phase 6: Send the
Book to the Bindery

iPhoto may come with only six basic book designs. But for
the creatively and technically inclined, that’s only the be-
ginning. You’re free to design new layouts of your own—
or modify Apple’s—if you know the secret.

All of the book designs are stored in a secret location as
.nib files, which you can edit using Apple’s free Developer
Tools suite. The hardest part of the whole process may just
be getting a copy of these pro-
grams. Here’s what you do:

Method 1: If you bought Mac OS
X, you’ll find this program on the
CD called Developer Tools that
came with your Mac OS X CD.

Method 2: You can get the De-
veloper Tools from Apple’s Web
site. That, however, entails be-
coming a member of Apple’s
developer’s club; an “Online”
membership is free. Sign up at http://connect.apple.com.

Once you’re on board, return to http:/
/connect.apple.com and sign in. Click
the Download Software link, then the
Mac OS X link. You at last arrive at the
Mac OS X software download page.
Download the most recent version of
the “Mac OS X Developer Tools” disk
image.

Either way: Open the Packages folder
of your Developer Tools disk or disk image, and then
double-click the DevTools.pkg icon to install Apple’s suite

Complete Design Freedom for Geeks

POWER USERS’ CLINIC

of programming tools. When the installation is complete,
you’ll find a new Developer folder on your hard drive.

Now you’re ready to view and edit Apple’s book-layout
files. To view them, Control-click the iPhoto program icon
in your Applications folder. From the contextual menu,
choose Show Package Contents. (Mac OS X programs may
look like single, self-contained icons, but most are in fact

cleverly disguised folders. Con-
trol-clicking is the key to open-
ing them up.)

In the iPhoto window, open the
Contents→Resources folder.
Here you find hundreds of tiny
graphics, each of which consti-
tutes one small piece of iPhoto’s
interface. You could, if you had
very little else to do, open these
graphics in a program like
Photoshop and edit them, taking

care not to change their dimensions. In that way, you could
modify the look of the buttons at the
bottom of the Organize screen, for ex-
ample.

But enough ogling the scenery! Find
and open the English.lproj→Books
folder. Here are six folders with famil-
iar names: Catalog, Classic, Picture
Book, and so on, as shown on the pre-
vious page. They correspond to the

canned book themes within iPhoto.
Continued
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POWER USERS’ CLINIC (CONTINUED)

Duplicate the folder of the book design that comes closest
to your dream design. Name the new folder whatever you
like—let’s call it Ansel & Gretel—and then open it. Deci-
phering the names of these files isn’t especially difficult:
Page-Storybook00Cover.nib is the cover, Page-
Storybook1.nib is the 1-photo-per-
page layout, and so on. (The let-
ters P and L in the various file
names—like Portfolio4PPLL.nib—
refer to various combinations of
portrait and landscape photos on
each page.) Double-click the layout
document that you want to edit first.

The page opens into a program called Interface Builder,
which is one of your Developer Tools. It works much like
a standard Mac drawing program. You can drag the text
and photo boxes around, make them bigger or smaller,
indent them (as shown
here at top), change their
fonts using the Format
menu), and so on. In the
Story Book layouts, you
can use the Layout→Send
to Back (and Bring to
Front) commands to con-
trol how the photos over-
lap each other. You have
multiple Undo’s at your disposal. (Unless you’re an XML
geek who knows what you’re doing, limit your editing to
moving text or photo boxes around, resizing them, and
overlapping them.)

When you’re finished tinkering, quit Interface Builder and
save your changes. In the next step, you have to make
iPhoto sit up and notice its newly enhanced layouts.

First, open the Developer→Applications folder and launch
the program called PropertyListEditor. Choose File→Open,
and navigate to the Applications→iPhoto→Contents→
Resources→English.lproj→Books folder. (Yes,
PropertyListEditor treats the iPhoto application icon as a

folder.) Open the Ansel & Gretel
folder, and then open the
book.xml file inside.

When the book.xml window
opens, click the flippy triangle
next to the word Root. Scan the
list (illustrated at left) until you
see the row called Name.

Double-click in the Value column and change the old lay-
out name (such as Catalog or Picture Book) to the name
you want, such as Ansel & Gretel (shown here). Choose
File→Save, and quit PropertyListEditor.

Finally, open your
Home→Library→Caches
folder and throw away
the iPhoto Cache folder.

When you next start up
iPhoto, you’ll see your
new book layout listed in
the Book mode’s Theme
pop-up menu (left)—and

the changes you made to its page designs.

All of this, of course, is at your own risk. If a book you
order based on your own design doesn’t look right, and
you call Apple to complain, you’re not likely to get a sym-
pathetic ear.


